projectPointToPlaneInView MethodStatic
Return ray intersection with a plane defined by a point and normal
projectPointToPlaneInView(spacePt: Point3d, planePt: Point3d, planeNormal: Vector3d, vp: Viewport, checkAccuDraw: boolean = false, checkACS: boolean = false): undefined | Point3d
see AccuDrawHintBuilder.getBoresite
Parameter | Type | Description |
---|---|---|
spacePt | Point3d | |
planePt | Point3d | |
planeNormal | Vector3d | |
vp | Viewport | |
checkAccuDraw | boolean | |
checkACS | boolean |
Returns - undefined | Point3d
Defined in
- core/frontend/src/AccuDraw.ts Line 3308
Last Updated: 20 June, 2023