projectPointToLineInView MethodStatic
Return ray intersection with a line defined by a point and direction
projectPointToLineInView(spacePt: Point3d, linePt: Point3d, lineDirection: Vector3d, vp: Viewport, checkAccuDraw: boolean = false, checkACS: boolean = false): undefined | Point3d
see AccuDrawHintBuilder.getBoresite
Parameter | Type | Description |
---|---|---|
spacePt | Point3d | |
linePt | Point3d | |
lineDirection | Vector3d | |
vp | Viewport | |
checkAccuDraw | boolean | |
checkACS | boolean |
Returns - undefined | Point3d
Defined in
- core/frontend/src/AccuDraw.ts Line 3322
Last Updated: 20 June, 2023