constructor Method
Create a GeometryParams given a Category Id for a GeometricElement and optional SubCategory Id. The appearance establishes the non-overriden display properties of graphics in a GeometricElement's GeometryStreamProps. A GeometricElement refers to a single Category through category, while it's graphics can appear on multiple SubCategories by adding a GeometryAppearanceProps with a SubCategory change to the GeometryStream.
GeometryParams(categoryId: string, subCategoryId: string = Id64.invalid): GeometryParams
note If a valid SubCategory Id is not supplied, the default SubCategory for the parent Category is used. To be considered valid, getCategoryId must refer to the specified Category Id.
Parameter | Type | Description |
---|---|---|
categoryId | string | |
subCategoryId | string |
Returns - GeometryParams
Defined in
- core/common/src/GeometryParams.ts Line 129
Last Updated: 20 June, 2023