AreaPattern.HatchDefLine Class
Implements
Methods
Name | Description | |
---|---|---|
constructor(json: AreaPattern.HatchDefLineProps): AreaPattern.HatchDefLine |
Properties
Name | Type | Description | |
---|---|---|---|
angle | undefined | Angle | Angle of hatch line, 0.0 if undefined | |
dashes | undefined | number[] | Array of gap and dash lengths for creating non-solid hatch lines, max of 20. | |
offset | undefined | Point2d | Offset of successive lines. | |
through | undefined | Point2d | Origin point (relative to placement) the hatch passes through, 0.0,0.0 if undefined |
Defined in
Last Updated: 20 June, 2023