FeatureAppearanceProvider.chain Function
Chain two FeatureAppearanceProviders together such that first
's getFeatureAppearance
function is applied before second
's.
If second
invokes source.getAppearance()
, the returned appearance will include any modifications applied by first
.
chain(first: FeatureAppearanceProvider, second: FeatureAppearanceProvider): FeatureAppearanceProvider
Parameter | Type | Description |
---|---|---|
first | FeatureAppearanceProvider | |
second | FeatureAppearanceProvider |
Returns - FeatureAppearanceProvider
Defined in
- core/common/src/FeatureSymbology.ts Line 871
Last Updated: 20 June, 2023