clone Method
Create a copy of this appearance, overriding any properties explicitly specified by changedProps
.
Example:
const base = FeatureAppearance.fromRgba(ColorDef.white); // transparency=0, rgb=white
const clone = base.clone({ transparency: undefined, weight: 5 }); // transparency=undefined, rgb=white, weight=5
clone(changedProps: FeatureAppearanceProps): FeatureAppearance
see FeatureAppearance.cloneProps.
Parameter | Type | Description |
---|---|---|
changedProps | FeatureAppearanceProps |
Returns - FeatureAppearance
Defined in
- core/common/src/FeatureSymbology.ts Line 210
Last Updated: 20 June, 2023