cloneProps Method
Convert this appearance to JSON, and override any properties explicitly specified by changedProps
in the result.
Example:
const base = FeatureAppearance.fromRgba(ColorDef.white); // transparency=0, rgb=white
const clone = base.cloneProps({ transparency: undefined, weight: 5 }); // transparency=undefined, rgb=white, weight=5
cloneProps(changedProps: FeatureAppearanceProps): FeatureAppearanceProps
see FeatureAppearance.clone.
Parameter | Type | Description |
---|---|---|
changedProps | FeatureAppearanceProps |
Returns - FeatureAppearanceProps
Defined in
- core/common/src/FeatureSymbology.ts Line 195
Last Updated: 20 June, 2023