clone Method
Create a copy of this MapLayerSettings, optionally modifying some of its properties.
clone(changedProps: Partial<ModelMapLayerProps>): ModelMapLayerSettings
Parameter | Type | Description |
---|---|---|
changedProps | Partial<ModelMapLayerProps> | JSON representation of the properties to change. |
Returns - ModelMapLayerSettings
A MapLayerSettings with all of its properties set to match those of this
, except those explicitly defined in changedProps
.
Defined in
- core/common/src/MapLayerSettings.ts Line 467
Last Updated: 20 June, 2023