spatialToEcef Method
Convert a point in this iModel's Spatial coordinates to an ECEF point using its IModel.ecefLocation.
spatialToEcef(spatial: Readonly<WritableXYAndZ>, result?: Point3d): Point3d
throws IModelError if IModel.isGeoLocated is false.
Parameter | Type | Description |
---|---|---|
spatial | Readonly<WritableXYAndZ> | A point in the iModel's spatial coordinates |
result | Point3d | If defined, use this for output |
Returns - Point3d
A Point3d in ECEF coordinates
Defined in
- core/common/src/IModel.ts Line 601
Last Updated: 20 June, 2023