ecefToSpatial Method
Convert a point in ECEF coordinates to a point in this iModel's Spatial coordinates using its IModel.ecefLocation.
ecefToSpatial(ecef: Readonly<WritableXYAndZ>, result?: Point3d): Point3d
throws IModelError if IModel.isGeoLocated is false.
note The resultant point will only be meaningful if the ECEF coordinate is close on the earth to the iModel.
Parameter | Type | Description |
---|---|---|
ecef | Readonly<WritableXYAndZ> | A point in ECEF coordinates |
result | Point3d | If defined, use this for output |
Returns - Point3d
A Point3d in this iModel's spatial coordinates
Defined in
- core/common/src/IModel.ts Line 610
Last Updated: 20 June, 2023