unquantize Method
Returns the unquantized point at the specified index in QPoint3dBufferBuilder.buffer.
unquantize(pointIndex: number, result?: Point3d): Point3d
throws Error if pointIndex
is out of bounds.
Parameter | Type | Description |
---|---|---|
pointIndex | number | The index of the point of interest, ranging from zero to one minus the number of points currently in the QPoint3dBufferBuilder.buffer. |
result | Point3d | If supplied, a Point3d to initialize with the result and return. |
Returns - Point3d
The unquantized point at the specified index in QPoint3dBufferBuilder.buffer.
Defined in
- core/common/src/QPoint.ts Line 982
Last Updated: 20 June, 2023