fromGeometricElement2d MethodStatic
Create a new GeometryStream iterator for a GeometricElement2d. If GeometricElement2dProps.placement is not undefined, placement relative entries will be returned transformed to world coordinates.
fromGeometricElement2d(element: Pick<GeometricElement2dProps, "geom" | "placement" | "category">): GeometryStreamIterator
throws IModelError if element.geom is undefined.
Parameter | Type | Description |
---|---|---|
element | Pick<GeometricElement2dProps, "geom" | "placement" | "category"> |
Returns - GeometryStreamIterator
Defined in
Last Updated: 20 June, 2023