computeContainment Method
Compute the degree to which a set of points is contained within these frustum planes.
computeContainment(points: Point3d[], sphere?: BoundingSphere, tolerance: number = 1.0e-8): FrustumPlanes.Containment
Parameter | Type | Description |
---|---|---|
points | Point3d[] | The points to test for containment. |
sphere | BoundingSphere | An optional spherical bounding volume fully containing all of the points. If supplied, this can reduce the amount of computation required. |
tolerance | number | The maximum distance from the interior of the frustum planes a point must be to be considered "contained". |
Returns - FrustumPlanes.Containment
the degree to which all of the points are contained within the clipping planes.
Defined in
Last Updated: 20 June, 2023