fromJSON MethodStatic
Create a ViewFlags from its JSON representation.
fromJSON(json?: ViewFlagProps): ViewFlags
note As described in ViewFlagProps, the JSON representation is awkward and error-prone. Prefer to use ViewFlags.create unless you need to deal with the persistence format directly.
note The default values differ slightly from those used by the constructor and ViewFlags.create:
- ViewFlags.clipVolume defaults to false.
- ViewFlags.constructions defaults to true.
- ViewFlags.lighting defaults to true unless all of ViewFlagProps.noSolarLight, ViewFlagProps.noCameraLights, and ViewFlagProps.noSourceLights are true.
Parameter | Type | Description |
---|---|---|
json | ViewFlagProps |
Returns - ViewFlags
Defined in
- core/common/src/ViewFlags.ts Line 473
Last Updated: 20 June, 2023