clone Method
Create a copy of this TerrainSettings, optionally modifying some of its properties.
clone(changedProps?: PlanarClipMaskProps): PlanarClipMaskSettings
Parameter | Type | Description |
---|---|---|
changedProps | PlanarClipMaskProps | JSON representation of the properties to change. |
Returns - PlanarClipMaskSettings
A PlanarClipMaskSettings with all of its properties set to match those ofthis
, except those explicitly defined in changedProps
.
Defined in
- core/common/src/PlanarClipMask.ts Line 238
Last Updated: 20 June, 2023