HiddenLine.Style Class
Describes the symbology with which edges should be drawn.
Methods
Name | Description | |
---|---|---|
equals(other: HiddenLine.Style): boolean | Returns true if this Style is equivalent to the supplied Style. | |
overrideColor(color: undefined | ColorDef): HiddenLine.Style | Create a Style equivalent to this one but with the specified color override. | |
overridePattern(pattern: undefined | LinePixels): HiddenLine.Style | Create a Style equivalent to this one but with the specified pattern override. | |
overrideWidth(width: undefined | number): HiddenLine.Style | Create a Style equivalent to this one but with the specified width override. | |
toJSON(): HiddenLine.StyleProps | ||
fromJSON(json?: HiddenLine.StyleProps, hidden?: "true"): HiddenLine.Style Static |
Properties
Name | Type | Description | |
---|---|---|---|
color Readonly | undefined | ColorDef | If defined, the color used to draw the edges. | |
defaultHidden StaticReadonly | HiddenLine.Style | ||
defaultVisible StaticReadonly | HiddenLine.Style | ||
pattern Readonly | undefined | LinePixels | If defined, the pixel pattern used to draw the edges. | |
width Readonly | undefined | number | If defined, the width of the edges in pixels. |
Defined in
- core/common/src/HiddenLine.ts Line 44
Last Updated: 20 June, 2023