update Method
Change selected properties of a reality model.
update(toUpdate: ContextRealityModel, updateProps: Partial<ContextRealityModelProps>): ContextRealityModel
throws Error if toUpdate
is not present in the list.
Parameter | Type | Description |
---|---|---|
toUpdate | ContextRealityModel | The reality model whose properties are to be modified. |
updateProps | Partial<ContextRealityModelProps> | The properties to change. |
Returns - ContextRealityModel
The updated reality model, identical to toUpdate
except for properties explicitly supplied by updateProps
.
Defined in
Last Updated: 20 June, 2023