clone Method
Create a copy of this BackgroundMapSettings, optionally modifying some of its properties.
clone(changedProps?: BackgroundMapProps): BackgroundMapSettings
Parameter | Type | Description |
---|---|---|
changedProps | BackgroundMapProps | JSON representation of the properties to change. |
Returns - BackgroundMapSettings
A BackgroundMapSettings with all of its properties set to match those of this
, except those explicitly defined in changedProps
.
Defined in
Last Updated: 20 June, 2023