TransientIdSequence Class
Generates unique Id64String values in sequence, which are guaranteed not to conflict with Ids associated with persistent elements or models. This is useful for associating stable, non-persistent identifiers with things like Decorators. A TransientIdSequence can generate a maximum of (2^40)-2 unique Ids.
Methods
Name | Description | |
---|---|---|
constructor(): TransientIdSequence | ||
getNext(): string | Generate and return the next transient Id64String in the sequence. | |
peekNext(): string | Preview the transient Id64String that will be returned by the next call to TransientIdSequence.getNext. |
Properties
Name | Type | Description | |
---|---|---|---|
next Accessor ReadOnly | string | Generate and return the next transient Id64String in the sequence. |
Defined in
- core/bentley/src/Id.ts Line 664
Last Updated: 20 June, 2023