Id64.Uint32Map<T> Class
A specialized replacement for Map<Id64String, T> optimized for performance-critical code.
see Id64.Uint32Set for implementation details.
Methods
Name | Description | |
---|---|---|
constructor<T>(): Id64.Uint32Map<T> | ||
clear(): void | Remove all entries from the map. | |
forEach(func: (lo: number, hi: number, value: T) => void): void | Execute a function against each entry in this map. | |
get(low: number, high: number): undefined | T | Get an entry from the map by Id components. | |
getById(id: string): undefined | T | Find an entry in the map by Id. | |
set(low: number, high: number, value: T): void | Set an entry in the map by Id components. | |
setById(id: string, value: T): void | Set an entry in the map by Id. |
Properties
Defined in
- core/bentley/src/Id.ts Line 611
Last Updated: 20 June, 2023