IModelHubStatus Enumeration
Statuses produced by APIs that interact with iModelHub, typically encountered as the errorNumber
of an IModelError.
Members
Name |
Value |
Description |
Success |
0 |
|
IMODELHUBERROR_BASE |
102400 |
|
Unknown |
102401 |
|
MissingRequiredProperties |
102402 |
|
InvalidPropertiesValues |
102403 |
|
UserDoesNotHavePermission |
102404 |
|
UserDoesNotHaveAccess |
102405 |
|
InvalidBriefcase |
102406 |
|
BriefcaseDoesNotExist |
102407 |
|
BriefcaseDoesNotBelongToUser |
102408 |
|
AnotherUserPushing |
102409 |
|
ChangeSetAlreadyExists |
102410 |
|
ChangeSetDoesNotExist |
102411 |
|
FileIsNotUploaded |
102412 |
|
iModelIsNotInitialized |
102413 |
|
ChangeSetPointsToBadSeed |
102414 |
|
OperationFailed |
102415 |
|
PullIsRequired |
102416 |
|
MaximumNumberOfBriefcasesPerUser |
102417 |
|
MaximumNumberOfBriefcasesPerUserPerMinute |
102418 |
|
DatabaseTemporarilyLocked |
102419 |
|
iModelIsLocked |
102420 |
|
CodesExist |
102421 |
|
LocksExist |
102422 |
|
iModelAlreadyExists |
102423 |
|
iModelDoesNotExist |
102424 |
|
FileDoesNotExist |
102425 |
|
FileAlreadyExists |
102426 |
|
LockDoesNotExist |
102427 |
|
LockOwnedByAnotherBriefcase |
102428 |
|
CodeStateInvalid |
102429 |
|
CodeReservedByAnotherBriefcase |
102430 |
|
CodeDoesNotExist |
102431 |
|
EventTypeDoesNotExist |
102432 |
|
EventSubscriptionDoesNotExist |
102433 |
|
EventSubscriptionAlreadyExists |
102434 |
|
ITwinIdIsNotSpecified |
102435 |
|
FailedToGetITwinPermissions |
102436 |
|
FailedToGetITwinMembers |
102437 |
|
ChangeSetAlreadyHasVersion |
102438 |
|
VersionAlreadyExists |
102439 |
|
JobSchedulingFailed |
102440 |
|
ConflictsAggregate |
102441 |
|
FailedToGetITwinById |
102442 |
|
DatabaseOperationFailed |
102443 |
|
SeedFileInitializationFailed |
102444 |
|
FailedToGetAssetPermissions |
102445 |
|
FailedToGetAssetMembers |
102446 |
|
ITwinDoesNotExist |
102447 |
|
LockChunkDoesNotExist |
102449 |
|
CheckpointAlreadyExists |
102450 |
|
CheckpointDoesNotExist |
102451 |
|
IMODELHUBERROR_REQUESTERRORBASE |
102656 |
|
UndefinedArgumentError |
102657 |
|
InvalidArgumentError |
102658 |
|
MissingDownloadUrlError |
102659 |
|
NotSupportedInBrowser |
102660 |
|
FileHandlerNotSet |
102661 |
|
FileNotFound |
102662 |
|
InitializationTimeout |
102663 |
|
Defined in
Last Updated:
20 June, 2023