ChangeSetStatus Enumeration
Error statuses produced by various Changeset operations, typically encountered as the errorNumber
of an IModelError.
Members
Name |
Value |
Description |
Success |
0 |
|
CHANGESET_ERROR_BASE |
90112 |
|
ApplyError |
90113 |
Error applying a change set when reversing or reinstating it |
ChangeTrackingNotEnabled |
90114 |
Change tracking has not been enabled. The ChangeSet API mandates this. |
CorruptedChangeStream |
90115 |
Contents of the change stream are corrupted and does not match the ChangeSet |
FileNotFound |
90116 |
File containing the changes to the change set is not found |
FileWriteError |
90117 |
Error writing the contents of the change set to the backing change stream file |
HasLocalChanges |
90118 |
Cannot perform the operation since the Db has local changes |
HasUncommittedChanges |
90119 |
Cannot perform the operation since current transaction has uncommitted changes |
InvalidId |
90120 |
Invalid ChangeSet Id |
InvalidVersion |
90121 |
Invalid version of the change set |
InDynamicTransaction |
90122 |
Cannot perform the operation since system is in the middle of a dynamic transaction |
IsCreatingChangeSet |
90123 |
Cannot perform operation since system is in the middle of a creating a change set |
IsNotCreatingChangeSet |
90124 |
Cannot perform operation since the system is not creating a change set |
MergePropagationError |
90125 |
Error propagating the changes after the merge |
NothingToMerge |
90126 |
No change sets to merge |
NoTransactions |
90127 |
No transactions are available to create a change set |
ParentMismatch |
90128 |
Parent change set of the Db does not match the parent id of the change set |
SQLiteError |
90129 |
Error performing a SQLite operation on the Db |
WrongDgnDb |
90130 |
ChangeSet originated in a different Db |
CouldNotOpenDgnDb |
90131 |
Could not open the DgnDb to merge change set |
MergeSchemaChangesOnOpen |
90132 |
Cannot merge changes in in an open DgnDb. Close the DgnDb, and process the operation when it is opened. |
ReverseOrReinstateSchemaChanges |
90133 |
Cannot reverse or reinstate schema changes. |
ProcessSchemaChangesOnOpen |
90134 |
Cannot process changes schema changes in an open DgnDb. Close the DgnDb, and process the operation when it is opened. |
CannotMergeIntoReadonly |
90135 |
Cannot merge changes into a Readonly DgnDb. |
CannotMergeIntoMaster |
90136 |
Cannot merge changes into a Master DgnDb. |
CannotMergeIntoReversed |
90137 |
Cannot merge changes into a DgnDb that has reversed change sets. |
DownloadCancelled |
90138 |
ChangeSet(s) download was cancelled. |
Defined in
Last Updated:
20 June, 2023