WorkspaceContainer.Props Interface
Properties that specify a WorkspaceContainer.
Extends
- Optional<CloudSqlite.ContainerProps, "accessToken">
Properties
Name | Type | Description | |
---|---|---|---|
isPublic | undefined | boolean | true if the container is public (doesn't require authentication) | |
syncOnConnect | undefined | boolean | attempt to synchronize (i.e. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
accessToken | undefined | string | Optional | token that grants access to the container. |
alias | undefined | string | Optional | an alias for the container. |
containerId | string | Optional | the name of the container. |
secure | undefined | boolean | Optional | if true, container is attached in "secure" mode (blocks are encrypted). |
writeable | undefined | boolean | Optional | if true, container is attached with write permissions, and accessToken must provide write access to the cloud container. |
Defined in
Last Updated: 20 June, 2023