insertWithCamera MethodStatic
Insert an SpatialViewDefinition with camera On
insertWithCamera(iModelDb: IModelDb, definitionModelId: string, name: string, modelSelectorId: string, categorySelectorId: string, displayStyleId: string, range: Range3d, standardView: StandardViewIndex = StandardViewIndex.Iso, cameraAngle: number = Angle.piOver2Radians): string
throws IModelError if there is an insert problem.
Parameter | Type | Description |
---|---|---|
iModelDb | IModelDb | Insert into this iModel |
definitionModelId | string | Insert the new OrthographicViewDefinition into this DefinitionModel |
name | string | The name/CodeValue of the view |
modelSelectorId | string | The ModelSelector that this view should use |
categorySelectorId | string | The CategorySelector that this view should use |
displayStyleId | string | The DisplayStyle3d that this view should use |
range | Range3d | Defines the view origin and extents |
standardView | StandardViewIndex | Optionally defines the view's rotation |
cameraAngle | number | Camera angle in radians. |
Returns - string
The Id of the newly inserted OrthographicViewDefinition element
Defined in
- backend/src/ViewDefinition.ts Line 436
Last Updated: 20 June, 2023