createWithCamera MethodStatic
Create an SpatialViewDefinition with camera.
createWithCamera(iModelDb: IModelDb, definitionModelId: string, name: string, modelSelectorId: string, categorySelectorId: string, displayStyleId: string, range: Range3d, standardView: StandardViewIndex = StandardViewIndex.Iso, cameraAngle: number = Angle.piOver2Radians): SpatialViewDefinition
throws IModelError if there is a problem creating the view
Parameter | Type | Description |
---|---|---|
iModelDb | IModelDb | The iModel |
definitionModelId | string | The DefinitionModel |
name | string | The name/CodeValue of the view |
modelSelectorId | string | The ModelSelector that this view should use |
categorySelectorId | string | The CategorySelector that this view should use |
displayStyleId | string | The DisplayStyle3d that this view should use |
range | Range3d | Defines the view origin and extents |
standardView | StandardViewIndex | Optionally defines the view's rotation |
cameraAngle | number | Camera angle in radians. |
Returns - SpatialViewDefinition
The newly constructed OrthographicViewDefinition element
Defined in
- backend/src/ViewDefinition.ts Line 397
Last Updated: 20 June, 2023