insert MethodStatic

Insert a ModelSelector to select which Models are displayed by a ViewDefinition.

insert(iModelDb: IModelDb, definitionModelId: string, name: string, models: Id64Array): string

throws IModelError if unable to insert the element.

Parameter Type Description
iModelDb IModelDb Insert into this iModel
definitionModelId string Insert the new ModelSelector into this DefinitionModel
name string The name/CodeValue of the ModelSelector
models Id64Array Array of models to select for display

Returns - string

The Id of the newly inserted ModelSelector element.

Defined in

Last Updated: 20 June, 2023