insert MethodStatic
Insert a DrawingViewDefinition
insert(iModelDb: IModelDb, definitionModelId: string, name: string, baseModelId: string, categorySelectorId: string, displayStyleId: string, range: Range2d): string
throws IModelError if there is an insert problem.
Parameter | Type | Description |
---|---|---|
iModelDb | IModelDb | Insert into this iModel |
definitionModelId | string | Insert the new DrawingViewDefinition into this DefinitionModel |
name | string | The name/CodeValue of the view |
baseModelId | string | The base DrawingModel |
categorySelectorId | string | The CategorySelector that this view should use |
displayStyleId | string | The DisplayStyle2d that this view should use |
range | Range2d | Defines the view origin and extents |
Returns - string
Defined in
- backend/src/ViewDefinition.ts Line 606
Last Updated: 20 June, 2023