insert MethodStatic
Insert a DisplayStyle3d for use by a ViewDefinition.
insert(iModelDb: IModelDb, definitionModelId: string, name: string, options?: DisplayStyleCreationOptions): string
throws IModelError if unable to insert the element.
Parameter | Type | Description |
---|---|---|
iModelDb | IModelDb | Insert into this iModel |
definitionModelId | string | Insert the new DisplayStyle3d into this DefinitionModel |
name | string | The name of the DisplayStyle3d |
options | DisplayStyleCreationOptions |
Returns - string
The Id of the newly inserted DisplayStyle3d element.
Defined in
- backend/src/DisplayStyle.ts Line 297
Last Updated: 20 June, 2023