create MethodStatic
Create a DisplayStyle3d for use by a ViewDefinition.
create(iModelDb: IModelDb, definitionModelId: string, name: string, options?: DisplayStyleCreationOptions): DisplayStyle3d
throws IModelError if unable to create the element.
Parameter | Type | Description |
---|---|---|
iModelDb | IModelDb | The iModel |
definitionModelId | string | The DefinitionModel |
name | string | The name/CodeValue of the DisplayStyle3d |
options | DisplayStyleCreationOptions |
Returns - DisplayStyle3d
The newly constructed DisplayStyle3d element.
Defined in
- backend/src/DisplayStyle.ts Line 264
Last Updated: 20 June, 2023