create MethodStatic
Create a CategorySelector to select which categories are displayed by a ViewDefinition.
create(iModelDb: IModelDb, definitionModelId: string, name: string, categories: Id64Array): CategorySelector
throws IModelError if unable to create the element.
Parameter | Type | Description |
---|---|---|
iModelDb | IModelDb | The iModel |
definitionModelId | string | The DefinitionModel |
name | string | The name of the CategorySelector |
categories | Id64Array | Array of categories to select for display |
Returns - CategorySelector
The newly constructed CategorySelector element.
Defined in
- backend/src/ViewDefinition.ts Line 146
Last Updated: 20 June, 2023