getOrCreateLinePixelsStyle MethodStatic
Query for a line style using the supplied LinePixels value (Code1-Code7) and create one if it does not already exist. Most applications should instead use LineStyleDefinition.Utils.createStrokePatternComponent to define a style with physical dash and gap lengths. Unlike other components, LineStyleDefinition.ComponentType.Internal uses the line code as the compId instead of a file property id.
getOrCreateLinePixelsStyle(imodel: IModelDb, scopeModelId: string, linePixels: LinePixels): string
throws IModelError if supplied an invalid LinePixels value or if unable to insert the line style definition element.
Parameter | Type | Description |
---|---|---|
imodel | IModelDb | |
scopeModelId | string | |
linePixels | LinePixels |
Returns - string
Defined in
- backend/src/LineStyle.ts Line 421
Last Updated: 20 June, 2023