createStyle MethodStatic
Insert a new line style with the supplied name.
createStyle(imodel: IModelDb, scopeModelId: string, name: string, props: LineStyleDefinition.StyleProps): string
throws IModelError if unable to insert the line style definition element.
Parameter | Type | Description |
---|---|---|
imodel | IModelDb | |
scopeModelId | string | |
name | string | |
props | LineStyleDefinition.StyleProps |
Returns - string
Defined in
- backend/src/LineStyle.ts Line 374
Last Updated: 20 June, 2023