LineStyleDefinition.Utils Class
Helper methods for creating and querying line styles
Methods
Name | Description | |
---|---|---|
constructor(): LineStyleDefinition.Utils | ||
createCompoundComponent(iModel: IModelDb, props: LineStyleDefinition.CompoundProps): LineStyleDefinition.StyleProps Static | Create a file property for a new compound component. | |
createPointSymbolComponent(iModel: IModelDb, props: LineStyleDefinition.PointSymbolProps): undefined | LineStyleDefinition.StyleProps Static | Create a file property for a new point symbol component. | |
createRasterComponent(iModel: IModelDb, props: LineStyleDefinition.RasterImageProps, image: Uint8Array): undefined | LineStyleDefinition.StyleProps Static | Create a file property for a new raster image component. | |
createStrokePatternComponent(iModel: IModelDb, props: LineStyleDefinition.StrokePatternProps): LineStyleDefinition.StyleProps Static | Create a file property for a new stroke pattern component. | |
createStrokePointComponent(iModel: IModelDb, props: LineStyleDefinition.StrokePointProps): LineStyleDefinition.StyleProps Static | Create a file property for a new stroke point component. | |
createStyle(imodel: IModelDb, scopeModelId: string, name: string, props: LineStyleDefinition.StyleProps): string Static | Insert a new line style with the supplied name. | |
getOrCreateContinuousStyle(imodel: IModelDb, scopeModelId: string, width?: number): string Static | Query for a continuous line style that can be used to create curves with physical width instead of weight in pixels and create one if it does not already exist. | |
getOrCreateLinePixelsStyle(imodel: IModelDb, scopeModelId: string, linePixels: LinePixels): string Static | Query for a line style using the supplied LinePixels value (Code1-Code7) and create one if it does not already exist. | |
queryStyle(imodel: IModelDb, scopeModelId: string, name: string): undefined | string Static | Query for an existing line style with the supplied name. |
Defined in
- backend/src/LineStyle.ts Line 303
Last Updated: 20 June, 2023