CloudSqlite.uploadDb Function
Upload a database into a CloudContainer
uploadDb(container: CloudSqlite.CloudContainer, props: CloudSqlite.TransferDbProps): Promise<void>
note this function requires that the write lock be held on the container
Parameter | Type | Description |
---|---|---|
container | CloudSqlite.CloudContainer | the CloudContainer holding the database. Must be connected. |
props | CloudSqlite.TransferDbProps | the properties that describe the database to be downloaded, plus optionally an onProgress function. |
Returns - Promise<void>
Defined in
- backend/src/CloudSqlite.ts Line 388
Last Updated: 20 June, 2023