connect Method
Connect this CloudContainer to a CloudCache for reading or writing its manifest, write lock, and databases.
connect(cache: CloudSqlite.CloudCache): void
note A CloudCache is a local directory holding copies of information from the cloud. Its content is persistent across sessions,
but this method must be called each session to (re)establish the connection to the cache. If the CloudCache was previously populated,
this method may be called and will succeed even when offline or without a valid accessToken
.
note all operations that access the contents of databases or the manifest require this method be called (isConnected === true
).
Parameter | Type | Description |
---|---|---|
cache | CloudSqlite.CloudCache |
Returns - void
Last Updated: 20 June, 2023