WebAppRpcLoggingBackend Class
Extends
Methods
Inherited methods
Name |
Inherited from |
Description |
buildOperationDescriptor(operation: RpcOperation | SerializedRpcOperation): string Protected |
WebAppRpcLogging |
|
findPathIds(path: string): { iModelId: string, iTwinId: string } Protected |
WebAppRpcLogging |
|
getRpcInterfaceName(g: string | RpcInterfaceDefinition<RpcInterface>): string Protected |
WebAppRpcLogging |
|
logRequest(loggerCategory: string, message: string, object: WebAppRpcRequest | SerializedRpcRequest): void Protected |
WebAppRpcLogging |
|
logResponse(loggerCategory: string, message: string, object: WebAppRpcRequest | SerializedRpcRequest, status: number, elapsed: number): void Protected |
WebAppRpcLogging |
|
initializeBackend(instance: WebAppRpcLogging): void Static |
WebAppRpcLogging |
|
initializeFrontend(instance: WebAppRpcLogging): void Static |
WebAppRpcLogging |
|
logProtocolEvent(event: RpcProtocolEvent, object: RpcRequest<any> | RpcInvocation): Promise<void> Static |
WebAppRpcLogging |
|
Defined in
Last Updated:
20 June, 2023