SubjectOwnsPartitionElements Class
Relates a parent Subject to InformationPartitionElement child elements.
Extends
Methods
Name | Description | |
---|---|---|
constructor(parentId: string, relClassName: string = SubjectOwnsPartitionElements.classFullName): SubjectOwnsPartitionElements |
Inherited methods
Name | Inherited from | Description |
---|---|---|
toJSON(): RelatedElementProps | ElementOwnsChildElements | |
fromJSON(json?: RelatedElementProps): undefined | RelatedElement Static | ElementOwnsChildElements | |
idFromJson(json: any): string Static | ElementOwnsChildElements | Accept the value of a navigation property that might be in the shortened format of just an id or might be in the full RelatedElement format. |
Properties
Name | Type | Description | |
---|---|---|---|
classFullName Static | string |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
id Readonly | string | ElementOwnsChildElements | The Id of the element to which this element is related. |
none StaticReadonly | RelatedElement | ElementOwnsChildElements | Used to null out an existing navigation relationship. |
relClassName Readonly | undefined | string | ElementOwnsChildElements | The full className of the relationship class. |
Defined in
Last Updated: 20 June, 2023