IpcHandler Class
Base class for all implementations of an Ipc interface.
Create a subclass to implement your Ipc interface. Your class should be declared like this:
class MyHandler extends IpcHandler implements MyInterface
to ensure all methods and signatures are correct.
Then, call MyClass.register
at startup to connect your class to your channel.
Methods
Name | Description | |
---|---|---|
constructor(): IpcHandler | ||
register(): RemoveFunction Static | Register this class as the handler for methods on its channel. |
Properties
Name | Type | Description | |
---|---|---|---|
channelName Accessor AbstractReadOnly | string | All subclasses must implement this method to specify their channel name. |
Defined in
- backend/src/IpcHost.ts Line 143
Last Updated: 20 June, 2023