insert MethodStatic
Insert a SpatialLocationPartition and a SpatialLocationModel that sub-models it.
insert(iModelDb: IModelDb, parentSubjectId: string, name: string, isPlanProjection?: boolean): string
throws IModelError if there is an insert problem.
Parameter | Type | Description |
---|---|---|
iModelDb | IModelDb | Insert into this iModel |
parentSubjectId | string | The SpatialLocationPartition will be inserted as a child of this Subject element. |
name | string | The name of the SpatialLocationPartition that the new SpatialLocationModel will sub-model. |
isPlanProjection | boolean | Optional value (default is false) that indicates if the contents of this model are expected to be in an XY plane. |
Returns - string
The Id of the newly inserted SpatialLocationPartition and SpatialLocationModel (same value).
Defined in
- backend/src/Model.ts Line 388
Last Updated: 20 June, 2023