insert MethodStatic
Insert a InformationRecordPartition and a InformationRecordModel that sub-models it.
insert(iModelDb: IModelDb, parentSubjectId: string, name: string): string
throws IModelError if there is an insert problem.
Parameter | Type | Description |
---|---|---|
iModelDb | IModelDb | Insert into this iModel |
parentSubjectId | string | The InformationRecordPartition will be inserted as a child of this Subject element. |
name | string | The name of the InformationRecordPartition that the new InformationRecordModel will sub-model. |
Returns - string
The Id of the newly inserted InformationRecordModel.
Defined in
- backend/src/Model.ts Line 471
Last Updated: 20 June, 2023