insert MethodStatic
Insert a DefinitionPartition and a DefinitionModel that sub-models it.
insert(iModelDb: IModelDb, parentSubjectId: string, name: string): string
throws IModelError if there is an insert problem.
Parameter | Type | Description |
---|---|---|
iModelDb | IModelDb | Insert into this iModel |
parentSubjectId | string | The DefinitionPartition will be inserted as a child of this Subject element. |
name | string | The name of the DefinitionPartition that the new DefinitionModel will sub-model. |
Returns - string
The Id of the newly inserted DefinitionModel.
Defined in
- backend/src/Model.ts Line 501
Last Updated: 20 June, 2023