openFile MethodStatic
Open a standalone iModel file.
openFile(filePath: string, openMode: OpenMode = OpenMode.ReadWrite, options?: SnapshotDbOpenArgs): StandaloneDb
throws IModelError if the file is not a standalone iModel.
see BriefcaseConnection.openStandalone to open a StandaloneDb from the frontend
Parameter | Type | Description |
---|---|---|
filePath | string | The path of the standalone iModel file. |
openMode | OpenMode | Optional open mode for the standalone iModel. The default is read/write. |
options | SnapshotDbOpenArgs |
Returns - StandaloneDb
Defined in
- backend/src/IModelDb.ts Line 2757
Last Updated: 20 June, 2023