openFile MethodStatic
Open a read-only iModel snapshot.
openFile(path: string, opts?: SnapshotDbOpenArgs): SnapshotDb
see SnapshotDb.close
throws IModelError If the file is not found or is not a valid snapshot.
Parameter | Type | Description |
---|---|---|
path | string | the full path of the snapshot iModel file to open. |
opts | SnapshotDbOpenArgs |
Returns - SnapshotDb
Defined in
- backend/src/IModelDb.ts Line 2628
Last Updated: 20 June, 2023