RequestNewBriefcaseArg Interface
The argument for BriefcaseManager.downloadBriefcase
Extends
Properties
Name | Type | Description | |
---|---|---|---|
onProgress | undefined | ProgressFunction | If present, a function called periodically during the download to indicate progress. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
accessToken Readonly | undefined | string | TokenArg | If present, the access token for the requested operation. |
asOf | undefined | IModelVersionProps | RequestNewBriefcaseProps | Id of the change set of the new briefcase. |
briefcaseId | undefined | number | RequestNewBriefcaseProps | The BriefcaseId for the new briefcase. |
fileName Readonly | undefined | string | RequestNewBriefcaseProps | Full path of local file to store the briefcase. |
iModelId Readonly | string | RequestNewBriefcaseProps | The iModelId for the new briefcase. |
iTwinId Readonly | string | RequestNewBriefcaseProps | iTwin that the iModel belongs to. |
Defined in
- backend/src/BriefcaseManager.ts Line 32
Last Updated: 20 June, 2023