validateSchemas MethodStatic
Determines if the schemas in the Db must or can be upgraded by comparing them with those included in the current version of the software.
validateSchemas(filePath: string, forReadWrite: boolean): SchemaState
throws IModelError If the Db was in an invalid state and that causes a problem with validating schemas
see BriefcaseDb.upgradeSchemas or StandaloneDb.upgradeSchemas
see ($docs/learning/backend/IModelDb.md#upgrading-schemas-in-an-imodel)
Returns - SchemaState
Defined in
- backend/src/IModelDb.ts Line 909
Last Updated: 20 June, 2023