updateGeometryGuid Method
Mark the geometry of GeometricModel as having changed, by recording an indirect change to its GeometryGuid property. Typically the GeometryGuid changes automatically when GeometricElements within the model are modified, but explicitly updating it is occasionally useful after modifying definition elements like line styles or materials that indirectly affect the appearance of GeometricElements that reference those definition elements in their geometry streams. Cached Tiles are only invalidated after the geometry guid of the model changes.
updateGeometryGuid(modelId: string): void
note This will throw IModelError with IModelStatus.VersionTooOld if a version of the BisCore schema older than 1.0.11 is present in the iModel.
throws IModelError if unable to update the geometry guid.
see TxnManager.onModelGeometryChanged for the event emitted in response to such a change.
Parameter | Type | Description |
---|---|---|
modelId | string |
Returns - void
Defined in
- backend/src/IModelDb.ts Line 1509
Last Updated: 20 June, 2023