queryRange Method
Computes the union of the volumes of all geoemtric elements within any number of GeometricModels, specified by model Id.
queryRange(ids: string | string[]): Promise<Range3d>
see IModelDb.Models.queryExtents to obtain discrete volumes for each model.
Parameter | Type | Description |
---|---|---|
ids | string | string[] |
Returns - Promise<Range3d>
Defined in
- backend/src/IModelDb.ts Line 1547
Last Updated: 20 June, 2023