ExportPartInfo Interface
Info provided to ExportPartFunction about graphics. See IModelDb.exportPartGraphics
Properties
Name | Type | Description | |
---|---|---|---|
color | number | The color and transparency for these graphics | |
geometryClass | GeometryClass | GeometryClass for these graphics | |
materialId | undefined | string | If defined, ID for the RenderMaterialElement for these graphics | |
mesh | ExportGraphicsMesh | The mesh for these graphics | |
textureId | undefined | string | If defined, ID for the Texture for these graphics |
Defined in
- backend/src/ExportGraphics.ts Line 181
Last Updated: 20 June, 2023