ExportGraphicsOptions Interface
Parameters for IModelDb.exportGraphics
Properties
Name | Type | Description | |
---|---|---|---|
angleTol | undefined | number | Max angle difference in radians for approximated face, see StrokeOptions. | |
chordTol | undefined | number | Max distance from a face to the original geometry, see StrokeOptions. | |
decimationTol | undefined | number | Max distance between mesh vertices for them to be collapsed. | |
elementIdArray | Id64Array | The source elements for the exported graphics | |
maxEdgeLength | undefined | number | Max length of any edge in generated faces, see StrokeOptions. | |
minBRepFeatureSize | undefined | number | BRep features with bounding boxes smaller than this size will not generate graphics. | |
minLineStyleComponentSize | undefined | number | The longest dimension of a line style's largest component must be at least this size in order for | |
onGraphics | ExportGraphicsFunction | A function to call for each unique element ID, color and texture combination | |
onLineGraphics | undefined | ExportLinesFunction | An optional function to call if line graphics are desired. | |
partInstanceArray | undefined | ExportPartInstanceInfo[] | If supplied, any references to GeometryPart elements found will be |
Defined in
- backend/src/ExportGraphics.ts Line 130
Last Updated: 20 June, 2023