queryInstanceChange MethodStatic
Queries the InstanceChange for the specified instance change id.
See also
ECDbChange.InstanceChange
ECClass in the ECDbChange ECSchema- Change Summary Overview
queryInstanceChange(iModel: BriefcaseDb, instanceChangeId: string): InstanceChange
throws IModelError if instance change does not exist for the specified id, or if the change cache file hasn't been attached, or in case of other errors.
Parameter | Type | Description |
---|---|---|
iModel | BriefcaseDb | iModel |
instanceChangeId | string | ECInstanceId of the InstanceChange (see ECDbChange.InstanceChange ECClass in the ECDbChange ECSchema) |
Returns - InstanceChange
Returns the requested InstanceChange object (see ECDbChange.InstanceChange
ECClass in the ECDbChange ECSchema)
Defined in
- backend/src/ChangeSummaryManager.ts Line 388
Last Updated: 20 June, 2023